Nooelec NESDR driver necessary?

I am trying to get a Nooelec NESDR working with ADSBexchange. I am using a Pi4.
ADSBexchange software loaded fine onto the Pi4 and it connects to the ADSBexchange server and I get two green checkmarks. However , I am still not seeing any aircraft from my feed. I have been in contact with Nooelec support and they told me I needed to follow the driver install instructions for “Ubuntu” Linux distro . As part of the instructions one has to modify a blacklist config file ( which I couldn’t find ) or the NESDR won’t work.
When I ran RTL_test it didn’t work.
Question: Is installing the driver necessary and is there more guidance with respect to the blacklist config file ?

There shouldn’t be any special driver needed for a NESDR, unless it’s some new model that I’ve not seen. Are you using the adsbexchange pi image, or did you roll your own? What output do you get from:

systemctl restart readsb
journalctl --no-pager -u readsb -l 20

Edit: also, what is your antenna situation? (type and location - indoors, near a window, attic, outdoors, etc)

Thanks for the input.

ran 'systemctl restart readsb ':
asked for authentication, I put in password then next line appeared

in red “Authentication complete”

then ran journalctl - - no-pager -u readsb -1 20

and I get the error "invalid option – ‘1’

not sure if I got all the spaces between the commands correct.

as far as the antenna goes: have tried several.
the small mag mount vertical that comes with the unit
a 3 element yagi
a micropatch antenna tuned to 1090 mhz

Mind you we don’t get a ton of planes flying overhead here but at least 4-5 a day come within 100km.

tnx for the help.
Please let me know what to try next.
The folks at Nooelec seemed adamant that a driver was needed.

yes, I used the Pi image from the ADSBexchange website. As I stated, I seem to connect just fine to the server.


Ahh, sorry, that was actually a lower-case ‘l’ (for lima) not a digit 1 (one)… but it should actually be an ‘n’, so make that:

journalctl --no-pager -u readsb -n 20

also you may need to put sudo infront of that